Ant Design Pro安装报错,${[openapiconfig].flat is not a function

Ant Design Pro安装报错,${[openapiconfig].flat is not a function

Ant Design Pro安装报错,${[openapiconfig].flat is not a function 解决方法:

1:node -v 检查node版本  保证node版本大于v12.0.0  

2:使用 yarn 管理 npm 依赖

npm i yarn tyarn -g 

tyarn -v

3:全局安装 umi,并确保版本是 2.0.0 或以上

yarn global add umi

 umi -v  

4:”出现‘umi‘ 不是内部或外部命令,也不是可运行的程序 或批处理文件或者提示 umi: command not found  

环境变量path添加:C:\Users\Administrator\AppData\Local\Yarn\bin

5:npm install  莫名其妙的出错

tyarn   install

npm start

默默
作者
默默

记录美好生活